Quick Login

Author Topic: Pictures needed inside TS-120V  (Read 141 times)

Offline PA1CJT

  • Leading Rate
  • *
  • Posts: 8
  • Country: nl
Pictures needed inside TS-120V
« on: November 07, 2019, 12:23:31 UTC »
Hi all, I have obtained an TS-120V did not receive, missed display (only dots) and no TX (not on SSB and not on CW. Searching the internet for causes and solutions and found some. So it is receiving again and it has digital dispaly working but still no TX.
When pushing the PTT or TX handle both the relays are activated but no signal. I placed a counter between the radio and the dummyload but no frequency displayed.

First I need to check if all cabling and connectors are properly and correct in place therefore I would have the pictures. I have already a spare set of capacitors for replacement.

First inspection shows no damaged resistors or blown capacitors.

I would love to bring this radio back alive but my repair skills are not that good.

I hope someone will read this and can support me with the pictures or advice.

vy 73
Kees
PA1CJT

Offline VE2TH

  • Rear Admiral
  • *
  • Posts: 204
  • Country: ca
Re: Pictures needed inside TS-120V
« Reply #1 on: November 25, 2019, 15:17:31 UTC »
Good afternoon, Kees,

Michel VE2TH here,

Well I have the complete .PDF SERVICE MANUAL, for your TS-130V transceivers

I don't know if you have it, but I can send it to you. There are all circuits and informations for any alignment , repairs, etc.

Have a nice day

72/73 Michel VE2TH  The QRP'er 

I love QRP/QRPp & CW

Offline PA1CJT

  • Leading Rate
  • *
  • Posts: 8
  • Country: nl
Re: Pictures needed inside TS-120V
« Reply #2 on: December 03, 2019, 04:37:55 UTC »
Hi Michel, already found the information needed. Rhe first checks I did looked OK but still not working. Well in reception everything is fine dut not (yet) on TX. So I'll go further with my investigation and it may rake a while. Have other equipment as well ;-)